|
DB di Sessione
|
Previous Top Next |
Questo ambiente visualizza tutte le tabelle create da TaLTaC2 nel corso del lavoro.
Per accedere al DB di Sessione, dal menù Visualizza selezionare Database di Sessione,
si aprirà l'omonima maschera che presenta una serie di liste.
Le liste sono consultabili selezionando la voce che interessa e premendo il tasto Apri lista selezionata o, in alternativa, facendo doppio click sulla voce.
Alla maschera si accede anche premendo il bottone nella barra degli strumenti.
Al centro della finestra principale del DB di Sessione sono visualizzate le tabelle correnti della sessione con il conteggio del numero di record.
All’inizio del lavoro questo ambiente è vuoto. Dopo il Parsing compaiono:
· il Vocabolario, popolato nei soli campi IDGF, Forma grafica, Occorrenze totali, e Lunghezza (altri campi popolati sono nascosti, per renderli visibili utilizzare la funzione Scopri campi nel Menù Formato).
Altri campi (già visibili ma privi di dati o non creati automaticamente dopo il Parsing) si popolano con l'utilizzo di altre funzionalità di TaLTaC2;
· la lista Alfabeto/Separatori,
· la lista [Descrizione Sezioni], con il riepilogo delle Sezioni in cui sono suddivisi i frammenti;
· la lista Frammenti con var categoriali e/o ex-post (testuali/quantitative), che riporta le modalità delle variabili categoriali associate ai frammenti all'atto del caricamento del Corpus in TaLTaC2 (vedi la voce Seleziona, assembla, struttura il Corpus dal Menù File).
Questa lista continua a popolarsi con nuove variabili categoriale ex-post create dall'utente, a seguito di categorizzazioni dei frammenti basate su ricerche tramite sequenze di testo complesse o parole chiave (query) eseguite nel modulo Ricerca Entità.
Altre liste compariranno nel Db di Sessione come risultato delle procedure di analisi del contenuto (per esempio la Lista dei segmenti dopo l’ individuazione dei segmenti) o a seguito di salvataggi di porzioni di liste già presenti nel Db di Sessione da parte dell'utente (tramite la funzione Salva nel DB di Sessione) o di importazioni di liste esterne.
Sul lato destro della maschera sono presenti una serie di pulsanti che permettono di importare nuove liste/tabelle (Importa), Rinominare o Eliminare quelle presenti e di Aggiornare l’elenco.
ATTENZIONE: Se si creano nuove liste quando il Db di Sessione è aperto, queste non vengono visualizzate nella finestra di gestione fino a quando non si preme il tasto Aggiorna.
In basso sono presenti i tasti per aprire la lista/tabella selezionata, per chiudere il Db di Sessione e per effettuare il Confronto fra liste.
Quando si apre il Db di Sessione si attivano le funzionalità dei Menù Records, Calcola e Formato.
ATTENZIONE: Nei Menu Records e Formato prima di effettuare qualunque operazione è necessario selezionare la colonna su cui si vuole operare.
Una volta aperta una tabella, per selezionare una colonna è necessario posizionarsi con il mouse sull’intestazione dei campi e, quando il cursore diventa una freccia nera rivolta verso il basso, cliccare con il tasto sinistro del mouse.
Per aumentare o diminuire la larghezza di un campo bisogna posizionare il mouse alla fine dell’intestazione del campo che si vuole modificare e, quando il cursore diventa una doppia freccia, premere il tasto sinistro del mouse e, tenendolo premuto, spostarlo verso destra o verso sinistra per restringere o allargare la colonna.
Nella parte inferiore della finestra sono visualizzate le informazioni sul numero di record e sul campo correntemente selezionato.
Le tabelle possono essere aperte in modalità di sola lettura (default) o in modalità scrittura, eliminando la spunta alla voce Sola lettura o direttamente dal Db di Sessione o dalla lista/tabella aperta. Solo in questo secondo caso è possibile modificare il contenuto dei campi (ad es. inserire Informazioni aggiuntive o integrare/correggere alcune categorie grammaticali). Alcuni campi sono comunque protetti dalla scrittura (per esempio Forma grafica e Occorrenze totali).
Attraverso il tasto Legenda, si accede alla finestra Legende dove è spiegato il significato dei codici che si troveranno nei campi Tagger, CAT (tab CAT) e Imprinting (tab Imprinting grammaticale) della tabella Vocabolario a seguito, per esempio, di procedure di tagging grammaticale o semantico.
Nel tab Connessione lessicale compare, invece, il significato dei codici presenti nel campo Lista di provenienza della tabella risultante dalla procedura di Connessione lessicale.
Nell'ultimo tab (Sintassi ricerca entità), infine, sono indicati gli operatori che si possono utilizzare per la ricerca di espressioni regolari all'interno del form Ricerca Entità insieme ad alcuni esempi sul loro utilizzo.
Il tasto Giornale della finestra DB di Sessione apre una tabella in cui sono elencate tutte le operazioni che si sono svolte nella sessione corrente, fin dalla sua creazione. Per ogni operazione vengono registrati la data di esecuzione ed i parametri con cui è stata effettuata. In questo modo è sempre possibile tenere traccia di come si è arrivati a certi risultati e quindi di come sia possibile ripeterli. E' inoltre molto utile per riuscire a capire il motivo di eventuali errori nella logica di analisi che possano generare errori.
ATTENZIONE: questa funzionalità è stata introdotta con la versione 2.0.3.8. Per le sessioni create con eseguibili precedenti detta versione il Giornale elencherà le sole operazioni eseguite dopo il passaggio da una versione precedente alla 2.0.3.8.
NOTA: quando si sta operando sulla tabella Giornale, i menu Calcola e Formato e le voci del menu Record Scrivi nel campo selezionato, Esegui piano di lavoro e Salva per correzione errori sono disabilitate.
SUGGERIMENTO: si consiglia di utilizzare la funzione Text/Data Mining del menu Record per effettuare ricerche mirate sulla tabella Giornale (ad es. per visualizzare le sole operazioni avvenute negli ultimi due giorni oppure le sole operazioni di Lessicalizzazione).
Il tasto Riepilogo occorrenze apre una finestra in cui vengono riepilogate il numero di forme e di occorrenze dell'intero corpus e, se si è effettuato il calcolo delle sub-occorrenze, delle singole partizioni.